Author Topic: Scroll not working on Firefox/Edge with v2.4.1  (Read 224 times)

Railton

  • Newbie
  • *
  • Posts: 2
    • View Profile
Scroll not working on Firefox/Edge with v2.4.1
« on: July 01, 2021, 05:40:08 pm »
Hi,

I've just upgraded from v2.2 to v2.4.1 in order to use the sortType feature.  I've not made any code changes.

With Chrome the grid works fine and I can use the vertical scroll bar to scroll down to see more records.
With Firefox and Edge I can move the scrollbar but the table rows don't move.

Any help appreciated for a fix.  Thanks.

Railton.

paramvir

  • Administrator
  • Hero Member
  • *****
  • Posts: 5198
    • View Profile
Re: Scroll not working on Firefox/Edge with v2.4.1
« Reply #1 on: July 01, 2021, 05:58:53 pm »
Scroll works fine in all browsers for the demos of v2.4.1: https://paramquery.com/demos

As part of the upgrade, you may have missed to replace the css files with the v2.4.1

Railton

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Scroll not working on Firefox/Edge with v2.4.1
« Reply #2 on: July 01, 2021, 07:12:29 pm »
Thanks for the quick reply, I did some checking on the includes.  I am using the cupertino jquery-ui theme with the following statement

<link rel='stylesheet' href='cupertino/jquery-ui.css' />

Using Firefox I removed these lines and the scrolling started working.  The strange thing is that when added back the scrolling still worked.

I closed all Edge and opened a new session.  Scrolling didn't work, I removed the lines, hit F5 and scrolling was working, added the lines back, hit F5, still working.  Closed browser and re-opened, still working.


I got someone else to check Edge and Firefox and they had no problems.  Looks like the issue is isolated to my computer.
« Last Edit: July 01, 2021, 07:23:08 pm by Railton »