Author Topic: When dragging a cell of Param query, "No rows to display." may be displayed  (Read 1824 times)

hideki.yoshikura

  • Pro Enterprise
  • Newbie
  • *
  • Posts: 35
    • View Profile
Param query version is using 6.2.4.
When dragging a cell of Param query, "No rows to display." may be displayed.
I would like to know the cause of this bug and how to resolve it.
This event occurs about once every 20 times.
The procedure for generating a bug is as follows.
1. Filter the grid cell of Param query.
2. Select a cell other than the cell filtered in 1. and drag to the position of the first cell in the same column.
3. Drop at the cell position in the first line.
4. The grid line is hidden and "No rows to display." is displayed.

Thanking you in advance

paramvir

  • Administrator
  • Hero Member
  • *****
  • Posts: 5090
    • View Profile
Sorry, the steps are not clear enough.

Could you please share a jsfiddle along with a walkthrough of the steps.

hideki.yoshikura

  • Pro Enterprise
  • Newbie
  • *
  • Posts: 35
    • View Profile
Thank you for your answer

I have created a screen shot of the procedure to realize the bug, so please check the confirmation of this bug again.

The procedure for generating a bug is as follows.
1. Filter the grid cell of Param query.
[img][/screen1.png]
2. Select a cell other than the cell filtered in 1. and drag to the position of the first cell in the same column.
[img][/screen2.png]
3. Drop at the cell position in the first line.
[img][/screen3.png]
4. The grid line is hidden and "No rows to display." is displayed.
[img][/screen4.png]

I would like to receive an answer again.

Thanking you in advance.

hideki.yoshikura

  • Pro Enterprise
  • Newbie
  • *
  • Posts: 35
    • View Profile

I'm sorry
Since the last post content was inappropriate,
We will ask again about the following contents

Param query version is using 6.2.4.
When autofilling cells in a Param query, "No rows to display." may be displayed.
I would like to know the cause of this bug and how to resolve it.
This event occurs about once every 20 times.
The procedure for generating a bug is as follows.

1. Filter the grid cell of Param query.(See attached image screen1.png)
2. Select cells other than the cells filtered in 1. and autofill at the position of the first cell in the same column.(See attached image screen2.png)
3. Instead of being autofilled, The grid line is hidden and "No rows to display." is displayed.(See attached image screen3.png)

Thanking you in advance.

hideki.yoshikura

  • Pro Enterprise
  • Newbie
  • *
  • Posts: 35
    • View Profile
Is this going to take some time to resolve?
If the question is not clear, we will ask you again.

paramvir

  • Administrator
  • Hero Member
  • *****
  • Posts: 5090
    • View Profile
I'm unable to reproduce the issue so far, please let me know more details which can be of help to reproduce it like browser version, any specific customization in your code, etc.

hideki.yoshikura

  • Pro Enterprise
  • Newbie
  • *
  • Posts: 35
    • View Profile
Thank you for your answer,

Although it is a browser, crome version is 83.0.4103.116.
I was able to reproduce it on the demo site below.
https://paramquery.com/pro/demos62

Here are the steps:
1.Filter the Freight column.
2.In the ShipCountry column,
When autofill is repeated several times, the border line of a cell may not be selected even if a cell is selected.
See attached file screen1.png

3.In this state, if you autofill up to the first cell, "no rows to display" is displayed.
See attached file screen2.png

Thanking you in advance.

paramvir

  • Administrator
  • Hero Member
  • *****
  • Posts: 5090
    • View Profile
I'm unable to reproduce steps 2 & 3 despite repeating autofill several times after filtering Freight column ( Step 1 ).

Have you made any changes / customization in the source code?

hideki.yoshikura

  • Pro Enterprise
  • Newbie
  • *
  • Posts: 35
    • View Profile
No customization is added to the source code.
The frequency of this phenomenon is fairly low.

When autofill is repeated several times, the border line of a cell may not be selected even if a cell is selected.

hideki.yoshikura

  • Pro Enterprise
  • Newbie
  • *
  • Posts: 35
    • View Profile
Is this a bug that cannot be reproduced?

paramvir

  • Administrator
  • Hero Member
  • *****
  • Posts: 5090
    • View Profile
No luck so far.